summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e7553bb82b..e2bf5f73da 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3210,11 +3210,20 @@ and is very extensible.")
(build-system python-build-system)
(arguments
`(#:phases
- (alist-cons-before
- 'check 'set-HOME
- ;; some tests require access to "$HOME"
- (lambda _ (setenv "HOME" "/tmp"))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ ;; Running tests from the source directory requires
+ ;; an "inplace" build with paths relative to CWD.
+ ;; http://scikit-learn.org/stable/developers/advanced_installation.html#testing
+ ;; Use the installed version instead.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ ;; some tests require access to "$HOME"
+ (setenv "HOME" "/tmp")
+ ;; Step out of the source directory just to be sure.
+ (chdir "..")
+ (zero? (system* "nosetests" "-v" "sklearn")))))))
(inputs
`(("openblas" ,openblas)))
(native-inputs