summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9d4880f924..8555249c17 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2685,6 +2685,21 @@ exec " gcc "/bin/" program
#:implicit-inputs? #f
,@(package-arguments bzip2)))))
+(define coreutils-boot0
+ (package
+ (inherit coreutils)
+ (source (bootstrap-origin (package-source coreutils)))
+ (name "coreutils-boot0")
+ (native-inputs `())
+ (inputs
+ `(("make" ,gnu-make-boot0)
+ ,@(%bootstrap-inputs+toolchain)))
+ (arguments
+ `(#:tests? #f
+ #:implicit-inputs? #f
+ #:guile ,%bootstrap-guile
+ ,@(package-arguments coreutils)))))
+
(define diffutils-boot0
(package
(inherit diffutils)
@@ -2807,6 +2822,7 @@ exec " gcc "/bin/" program
(define (%boot0-inputs)
`(("bzip2" ,bzip2-boot0)
+ ("coreutils" ,coreutils-boot0)
("diffutils" ,diffutils-boot0)
("findutils" ,findutils-boot0)
("file" ,file-boot0)