summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a0642bdfab..97eb3651a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24067,6 +24067,49 @@ which supports the spawning of processes using the API of the standard
library's @code{threading} module.")
(license license:bsd-3)))
+(define-public python-toolrack
+ (package
+ (name "python-toolrack")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/albertodonato/toolrack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ych11b7nchnkhqgf7dgivbvn2lzafjsi7nhb1an5zjjyns39gpx"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda _
+ (substitute* "toolrack/aio/tests/test_process.py"
+ (("/bin/sh")
+ (which "sh")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "--pyargs" "toolrack"
+ "-k"
+ (string-append
+ ;; These tests fail for unknown reason comparing the
+ ;; expected output of shell scripts.
+ "not test_parse_stderr "
+ "and not test_parse_no_ending_newline "
+ "and not test_parse_stdout"))))))))
+ (native-inputs (list python-pytest python-pytest-asyncio
+ python-pytest-mock))
+ (home-page "https://github.com/albertodonato/toolrack")
+ (synopsis "Collection of Python utility functions and classes")
+ (description "This package provides a collection of miscellaneous utility
+functions and classes.")
+ (license license:lgpl3+)))
+
(define-public python-toolz
(package
(name "python-toolz")