summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/wget.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 93a40c487a..4940156db5 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -96,6 +96,14 @@ in downloaded documents to relative links.")
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
+ (add-after 'unpack 'remove-dead-paste-site
+ ;; This phase is adaped from the following patch:
+ ;; https://gitweb.gentoo.org/repo/gentoo.git/tree/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
+ (lambda _
+ (substitute* "wgetpaste"
+ ((" poundpython\"") "\"")
+ (("-poundpython") "-dpaste"))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))