summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/sml.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/sml.scm b/gnu/packages/sml.scm
index 1d1ccf6d8c..04411c02c3 100644
--- a/gnu/packages/sml.scm
+++ b/gnu/packages/sml.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2017, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
-;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,7 +35,7 @@
(define-public polyml
(package
(name "polyml")
- (version "5.8.2")
+ (version "5.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -44,16 +44,14 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1y3i919kzylvhwfsi6adnc0ah0xahl6ncna0g5bcjyhxsq2416rn"))))
+ "0hhij8y0kvchg9rarzrcr9i0f629s2chbg258b0jscicjv9ghi6w"))))
(build-system gnu-build-system)
(inputs
(list gmp lesstif libffi libx11 libxt))
(arguments
'(#:configure-flags
- (list "--with-system-libffi=yes"
- "--with-x=yes"
- "--with-threads=yes"
- "--with-gmp=yes")
+ (list "--with-gmp"
+ "--with-x")
#:phases
(modify-phases %standard-phases
(add-after 'build 'build-compiler