summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/guile-present-coding.patch16
2 files changed, 17 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 56dc0849f1..4acbb51aad 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -487,6 +487,7 @@ dist_patch_DATA = \
gnu/packages/patches/guile-arm-fixes.patch \
gnu/packages/patches/guile-default-utf8.patch \
gnu/packages/patches/guile-linux-syscalls.patch \
+ gnu/packages/patches/guile-present-coding.patch \
gnu/packages/patches/guile-relocatable.patch \
gnu/packages/patches/guile-rsvg-pkgconfig.patch \
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
diff --git a/gnu/packages/patches/guile-present-coding.patch b/gnu/packages/patches/guile-present-coding.patch
new file mode 100644
index 0000000000..0655726158
--- /dev/null
+++ b/gnu/packages/patches/guile-present-coding.patch
@@ -0,0 +1,16 @@
+The tests/org-mode.scm tests expects 'jpl-outline-es' to be read as UTF-8.
+
+--- guile-present-0.3.0/tests/org-mode.scm 2014-09-23 22:29:51.426705753 +0200
++++ guile-present-0.3.0/tests/org-mode.scm 2014-09-23 22:30:09.634705548 +0200
+@@ -194,9 +194,10 @@
+ "(Just another hacker)"
+ "wingo@fluendo.com")
+ (p "Julien Moutte, CEO" "julien@fluendo.com")))
++ (with-fluids ((%default-port-encoding "UTF-8"))
+ (call-with-input-file
+ (in-vicinity *top-srcdir* "tests/jpl-outline-es")
+- org->presentation)))
++ org->presentation))))
+
+ (setlocale LC_ALL "")
+ (exit-with-summary (run-all-defined-test-cases))