summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/irc.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 0e29f8a691..07b72bdb94 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -88,17 +88,16 @@ irssi, but graphical.")
(build-system gnu-build-system)
(arguments
`(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (ncurses (assoc-ref inputs "ncurses")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-ncurses=" ncurses)))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (ncurses (assoc-ref inputs "ncurses")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-ncurses=" ncurses)))))))))
(inputs
`(("glib" ,glib)
("ncurses" ,ncurses)