summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1ae37d7105..9e8bbf97be 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2516,14 +2516,14 @@ exec " gcc "/bin/" program
;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
;; to incorrect handling of the [:alpha:] regexp character
;; class. Ignore it.
- ,@(if (string=? (%current-system)
- (or "x86_64-linux" "i686-linux"))
- '((add-before 'check 'skip-fnmatch-test
- (lambda _
- (substitute* "gnulib-tests/Makefile"
- (("^XFAIL_TESTS =")
- "XFAIL_TESTS = test-fnmatch ")))))
- '()))))))))
+ ,@(if (member (%current-system)
+ '("x86_64-linux" "i686-linux"))
+ '((add-before 'check 'skip-fnmatch-test
+ (lambda _
+ (substitute* "gnulib-tests/Makefile"
+ (("^XFAIL_TESTS =")
+ "XFAIL_TESTS = test-fnmatch ")))))
+ '()))))))))
(define file
(package