summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm27
-rw-r--r--gnu/packages/python-xyz.scm2
2 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4e1b8e802c..b49f9de157 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1307,33 +1307,6 @@ same arguments.")
`(("python2-mock" ,python2-mock)
,@(package-propagated-inputs base))))))
-(define-public python-pytest-mock-3
- (package
- (inherit python-pytest-mock)
- (version "3.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mock" version))
- (sha256
- (base32
- "0qhfmd05z3g88bnwq6644jl6p5wy01i4yy7h8883z9jjih2pl8a0"))))
- (properties '())
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"
- ;; TODO: these fail for unclear reasons
- "-k"
- (string-append
- "not test_standalone_mock"
- " and not test_detailed_introspection_async"))))))))))
-
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 577353e65d..07c9127c19 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23107,7 +23107,7 @@ standard error channel (stderr) in your program.")
("python-iniconfig" ,python-iniconfig)
("python-mock" ,python-mock)
("python-pytest" ,python-pytest-6)
- ("python-pytest-mock" ,python-pytest-mock-3)
+ ("python-pytest-mock" ,python-pytest-mock)
("python-pytest-trio" ,python-pytest-trio)
("python-setuptools-scm" ,python-setuptools-scm)
("python-trustme" ,python-trustme)