summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 06f8bbdbea..593d47d7a1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -520,7 +520,18 @@ synchronous execution of all clients, and low latency operation.")
(arguments
`(#:tests? #f ; no check target
#:configure-flags '("--dbus"
- "--alsa")))
+ "--alsa")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'set-linkflags
+ (lambda _
+ ;; Add $libdir to the RUNPATH of all the binaries.
+ (substitute* "wscript"
+ ((".*CFLAGS.*-Wall.*" m)
+ (string-append m
+ " conf.env.append_unique('LINKFLAGS',"
+ "'-Wl,-rpath=" %output "/lib')\n"))))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("dbus" ,dbus)