summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f131734f76..bd222d9cc9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3238,32 +3238,28 @@ current match, total matches and exit status.
(license license:gpl3+)))
(define-public emacs-go-mode
- (package
- (name "emacs-go-mode")
- (version "1.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dominikh/go-mode.el")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nd2h50yb0493wvf1h7fzplq45rmqn2w7kxpgnlxzhkvq99v8vzf"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'make-writable
- (lambda _
- (for-each make-file-writable (find-files "." "\\.el$")))))))
- (home-page "https://github.com/dominikh/go-mode.el")
- (synopsis "Go mode for Emacs")
- (description
- "This package provides go-mode, an Emacs mode for working with software
+ ;; XXX: Upstream did not tag last release. The commit below matches version
+ ;; bump.
+ (let ((commit "3273fcece5d9ab7edd4f15b2d6bce61f4e5a0666"))
+ (package
+ (name "emacs-go-mode")
+ (version "1.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dominikh/go-mode.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00qzn136d8cl3szbi44xf3iiv75r6n1m7wwgldmzn4i5mpz8dbq7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dominikh/go-mode.el")
+ (synopsis "Go mode for Emacs")
+ (description
+ "This package provides go-mode, an Emacs mode for working with software
written in the Go programming language.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public emacs-google-maps
;; There has been no new release tag since 2013.