summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 531f866b58..90f3500f11 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -436,6 +436,18 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(lambda _
(substitute* "texk/kpathsea/config.h"
(("#define ST_NLINK_TRICK") ""))))
+
+ ,@(if (target-arm32?)
+ `((add-after 'unpack 'skip-faulty-test
+ (lambda _
+ ;; Skip this faulty test on armhf-linux:
+ ;; https://issues.guix.gnu.org/54055
+ (substitute* '("texk/mendexk/tests/mendex.test"
+ "texk/upmendex/tests/upmendex.test")
+ (("^TEXMFCNF=" all)
+ (string-append "exit 77 # skip\n" all))))))
+ '())
+
(add-after 'check 'customize-texmf.cnf
;; The default texmf.cnf is provided by this package, texlive-bin.
;; Every variable of interest is set relatively to the GUIX_TEXMF