summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 98e3e6a8d5..811650de24 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3762,8 +3762,12 @@ for Flask.")
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-some-tests
+ (add-before 'check 'adjust-tests
(lambda _
+ ;; Fix for Python 3.9 compatibility.
+ (substitute* "tests/test_script.py"
+ (("self\\.t\\.isAlive")
+ "self.t.is_alive"))
;; This test requires 'postcss' and 'babel' which are
;; not yet available in Guix.
(delete-file "tests/test_filters.py")))