summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 045f5d21ae..52dff21e4d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18882,11 +18882,12 @@ mode.")
`(#:phases
(modify-phases %standard-phases
(add-before 'install 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "emacs" "--batch" "-L" "."
- "-l" "test/m-buffer-test.el"
- "-l" "test/m-buffer-at-test.el"
- "-f" "ert-run-tests-batch-and-exit"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "emacs" "--batch" "-L" "."
+ "-l" "test/m-buffer-test.el"
+ "-l" "test/m-buffer-at-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
(build-system emacs-build-system)
(home-page "https://github.com/phillord/m-buffer-el")
(synopsis "List oriented buffer operations for Emacs")