summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pdf.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index dd6fc0076b..4757ef7534 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -95,14 +95,13 @@
;; Saves 8 MiB of .a files.
"--disable-static")
#:phases
- (alist-cons-before
- 'configure 'setenv
- (lambda _
- (setenv "CPATH"
- (string-append (assoc-ref %build-inputs "openjpeg-1")
- "/include/openjpeg-1.5"
- ":" (or (getenv "CPATH") ""))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "CPATH"
+ (string-append (assoc-ref %build-inputs "openjpeg-1")
+ "/include/openjpeg-1.5"
+ ":" (or (getenv "CPATH") ""))))))))
(synopsis "PDF rendering library")
(description
"Poppler is a PDF rendering library based on the xpdf-3.0 code base.")