summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/gps.scm27
-rw-r--r--gnu/packages/patches/gpsbabel-minizip.patch13
-rw-r--r--gnu/packages/patches/gpsbabel-qstring.patch69
4 files changed, 14 insertions, 98 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2e026cb252..396baae4ab 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -39,6 +39,7 @@
# Copyright © 2020 Martin Becze <mjbecze@riseup.net>
# Copyright © 2020 Malte Frank Gerdes <mate.f.gerdes@gmail.com>
# Copyright © 2020 Vinicius Monego <monego@posteo.net>
+# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
#
# This file is part of GNU Guix.
#
@@ -1113,8 +1114,6 @@ dist_patch_DATA = \
%D%/packages/patches/go-skip-gc-test.patch \
%D%/packages/patches/gpm-glibc-2.26.patch \
%D%/packages/patches/gpodder-disable-updater.patch \
- %D%/packages/patches/gpsbabel-minizip.patch \
- %D%/packages/patches/gpsbabel-qstring.patch \
%D%/packages/patches/grantlee-merge-theme-dirs.patch \
%D%/packages/patches/grep-timing-sensitive-test.patch \
%D%/packages/patches/grocsvs-dont-use-admiral.patch \
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index e0f489f8de..fdb64f0902 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,21 +52,18 @@
(define-public gpsbabel
(package
(name "gpsbabel")
- (version "1.5.4")
+ (version "1.7.0")
(source (origin
- (method url-fetch)
- ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
- ;; get it from elsewhere.
- (uri (string-append
- "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
- version ".orig.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gpsbabel/gpsbabel")
+ (commit (string-append
+ "gpsbabel_"
+ (string-replace-substring version "." "_")))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "19hykxhyl567gf8qcrl33qhv95w0g4vxw9r3h9b8d8plx9bnaf8l"))
- (patches (search-patches
- "gpsbabel-minizip.patch"
- ;; XXX: Remove this patch on the next release.
- "gpsbabel-qstring.patch"))
+ "010g0vd2f5knpq5p7qfnl31kv3r8m5sjdsafcinbj5gh02j2nzpy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -87,8 +85,9 @@
#:tests? #f))
(inputs
`(("expat" ,expat)
- ("zlib" ,zlib)
- ("qtbase" ,qtbase)))
+ ("libusb" ,libusb)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
(native-inputs
`(("which" ,which)
("qttools" ,qttools)
diff --git a/gnu/packages/patches/gpsbabel-minizip.patch b/gnu/packages/patches/gpsbabel-minizip.patch
deleted file mode 100644
index 8f3bb36f57..0000000000
--- a/gnu/packages/patches/gpsbabel-minizip.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Patch taken from https://sources.debian.org/data/main/g/gpsbabel/1.5.3-2/debian/patches/use_minizip.
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -120,7 +120,7 @@ LIBOBJS = queue.o route.o waypt.o filter
- src/core/usasciicodec.o\
- src/core/ziparchive.o \
- $(GARMIN) $(JEEPS) $(SHAPE) @ZLIB@ $(FMTS) $(FILTERS)
--OBJS = main.o globals.o $(LIBOBJS) @FILEINFO@
-+OBJS = main.o globals.o $(MINIZIP) $(LIBOBJS) @FILEINFO@
-
- DEPFILES = $(OBJS:.o=.d)
- \ No newline at end of file
diff --git a/gnu/packages/patches/gpsbabel-qstring.patch b/gnu/packages/patches/gpsbabel-qstring.patch
deleted file mode 100644
index 8ba1a7213b..0000000000
--- a/gnu/packages/patches/gpsbabel-qstring.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Extracted from following patch of gpsbabel:
-https://github.com/gpsbabel/gpsbabel/commit/604178aa8ad4d3c3ad218df24c1e9a6a1f683bb3
-
-From 604178aa8ad4d3c3ad218df24c1e9a6a1f683bb3 Mon Sep 17 00:00:00 2001
-From: Harel Mazor <harel.mazor@gmail.com>
-Date: Tue, 24 Jan 2017 00:35:04 +0200
-Subject: [PATCH] Added geojson read capablity, moved magic strings to
- constants, fixed windows compilation issues.
-
---- a/tef_xml.cc
-+++ b/tef_xml.cc
-@@ -72,11 +72,11 @@ tef_start(xg_string args, const QXmlStreamAttributes* attrv)
- bool valid = false;
-
- foreach(QXmlStreamAttribute attr, *attrv) {
-- if (attr.name().compare("Comment", Qt::CaseInsensitive) == 0) {
-- if (attr.value().compare("TourExchangeFormat", Qt::CaseInsensitive) == 0) {
-+ if (attr.name().compare(QString("Comment"), Qt::CaseInsensitive) == 0) {
-+ if (attr.value().compare(QString("TourExchangeFormat"), Qt::CaseInsensitive) == 0) {
- valid = true;
- }
-- } else if (attr.name().compare("Version", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("Version"), Qt::CaseInsensitive) == 0) {
- version = attr.value().toString().toDouble();
- }
- }
-@@ -95,9 +95,9 @@ tef_header(xg_string args, const QXmlStreamAttributes* attrv)
- {
- route = route_head_alloc();
- foreach(QXmlStreamAttribute attr, *attrv) {
-- if (attr.name().compare("Name", Qt::CaseInsensitive) == 0) {
-+ if (attr.name().compare(QString("Name"), Qt::CaseInsensitive) == 0) {
- route->rte_name = attr.value().toString().trimmed();
-- } else if (attr.name().compare("Software", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("Software"), Qt::CaseInsensitive) == 0) {
- route->rte_desc = attr.value().toString().trimmed();
- }
- }
-@@ -248,20 +248,20 @@ tef_item_start(xg_string args, const QXmlStreamAttributes* attrv)
- QString attrstr = attr.value().toString();
- QByteArray attrtext = attrstr.toUtf8();
-
-- if (attr.name().compare("SegDescription", Qt::CaseInsensitive) == 0) {
-+ if (attr.name().compare(QString("SegDescription"), Qt::CaseInsensitive) == 0) {
- wpt_tmp->shortname = attrstr.trimmed();
-- } else if (attr.name().compare("PointDescription", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("PointDescription"), Qt::CaseInsensitive) == 0) {
- wpt_tmp->description = attrstr.trimmed();
-- } else if (attr.name().compare("ViaStation", Qt::CaseInsensitive) == 0 &&
-- attr.value().compare("true", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("ViaStation"), Qt::CaseInsensitive) == 0 &&
-+ attr.value().compare(QString("true"), Qt::CaseInsensitive) == 0) {
- wpt_tmp->wpt_flags.fmt_use = 1; /* only a flag */
-
- /* new in TEF V2 */
-- } else if (attr.name().compare("Instruction", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("Instruction"), Qt::CaseInsensitive) == 0) {
- wpt_tmp->description = attrstr.trimmed();
-- } else if (attr.name().compare("Altitude", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("Altitude"), Qt::CaseInsensitive) == 0) {
- wpt_tmp->altitude = attrstr.toDouble();
-- } else if (attr.name().compare("TimeStamp", Qt::CaseInsensitive) == 0) {
-+ } else if (attr.name().compare(QString("TimeStamp"), Qt::CaseInsensitive) == 0) {
- /* nothing for the moment */
- }
- }
---
-2.16.1
-