summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8471d03aa1..ae0dddeb66 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1375,7 +1375,20 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
(list
;; Add the output lib directory to the RUNPATH.
(string-append "--ldflags=-Wl,-rpath=" %output "/lib")
- "--cxxflags=-std=c++11")))
+ "--cxxflags=-std=c++11")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-boost-includes
+ (lambda _
+ (substitute* "src/headers/gx_internal_plugins.h"
+ (("namespace gx_jack" m)
+ (string-append "#include <boost/noncopyable.hpp>\n" m)))
+ (substitute* '("src/headers/gx_system.h"
+ "src/headers/gx_parameter.h"
+ "src/headers/gx_json.h")
+ (("namespace gx_system" m)
+ (string-append "#include <boost/noncopyable.hpp>\n" m)))
+ #t)))))
(inputs
`(("libsndfile" ,libsndfile)
("boost" ,boost)