summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 9708bd0175..80ace85e87 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1928,6 +1928,44 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxinerama library.")
(license license:expat)))
+(define-public julia-xorg-libxrandr-jll
+ (package
+ (name "julia-xorg-libxrandr-jll")
+ (version "1.5.2+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXrandr_jll.jl")
+ (commit (string-append "Xorg_libXrandr-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y4gsw5x643qdamf932agzdlyayzp63pn8j7j0lckd6dzqfdz46g"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXrandr\"")
+ (string-append "\"" (assoc-ref inputs "libxrandr") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxrandr" ,libxrandr)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libxext-jll" ,julia-xorg-libxext-jll)
+ ("julia-xorg-libxrender-jll" ,julia-xorg-libxrender-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXrandr_jll.jl")
+ (synopsis "Libxrandr library wrappers")
+ (description "This package provides a wrapper for the libxrandr library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxrender-jll
(package
(name "julia-xorg-libxrender-jll")