summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d79cb135e6..2f2ef2ffd9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -728,10 +728,13 @@ concepts.")
(description
"The lockfile package exports a LockFile class which provides a simple
API for locking files.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-lockfile))))))
(define-public python2-lockfile
- (package-with-python2 python-lockfile))
+ (let ((base (package-with-python2 (strip-python2-variant python-lockfile))))
+ (package
+ (inherit base))))
(define-public python-mock
(package