summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 68c95d09ce..b1ee527c7a 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,6 +46,13 @@
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-bit-reproducable
+ (lambda _
+ (substitute* "src/version.c"
+ ((" VIM_VERSION_LONG_DATE") " VIM_VERSION_LONG")
+ ((" __DATE__") "")
+ ((" __TIME__") ""))
+ #t))
(add-after 'configure 'patch-config-files
(lambda _
(substitute* "runtime/tools/mve.awk"