summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/llvm.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7efabd6a2b..358fbfff0a 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -476,6 +476,12 @@ code analysis tools.")
(((names . directories) ...)
(union-build out directories)))
+ ;; Create 'cc' and 'c++' so that one can use it as a
+ ;; drop-in replacement for the default tool chain and
+ ;; have configure scripts find the compiler.
+ (symlink "clang" (string-append out "/bin/cc"))
+ (symlink "clang++" (string-append out "/bin/c++"))
+
(union-build (assoc-ref %outputs "debug")
(list (assoc-ref %build-inputs
"libc-debug")))