summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm5
-rw-r--r--guix/build-system/python.scm2
2 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4567a91e51..8c34ff2e46 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9097,10 +9097,7 @@ to provide a high-level synchronous API on top of the libev event loop.")
(version "16.2.0")
(source (origin
(method url-fetch)
- (uri (list (pypi-uri "Twisted" version ".tar.bz2") ; 404
- (string-append
- "https://pypi.io/packages/source/T/Twisted/"
- "Twisted-" version ".tar.bz2")))
+ (uri (pypi-uri "Twisted" version ".tar.bz2"))
(sha256
(base32
"0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index c3d6c62404..705943eb73 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -48,7 +48,7 @@
"Return a URI string for the Python package hosted on the Python Package
Index (PyPI) corresponding to NAME and VERSION. EXTENSION is the file name
extension, such as '.tar.gz'."
- (string-append "https://pypi.python.org/packages/source/"
+ (string-append "https://pypi.io/packages/source/"
(string-take name 1) "/" name "/"
name "-" version extension))