summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/debug.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 94312e7c05..24d17d95b0 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -199,6 +199,11 @@ tools that process C/C++ code.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-linkage
+ (lambda _
+ (substitute* "clang_delta/CMakeLists.txt"
+ (("\\$\\{LLVM_LINK_LLVM_DYLIB\\}") "True")
+ ((" LLVM") " LLVMSupport"))))
(add-before 'build 'hardcode-paths
(lambda _
(substitute* "cvise.py"