summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tls.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f5ffe42b91..e577421fac 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -717,6 +717,13 @@ number generator")
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pem (string-append (assoc-ref inputs "libressl")
+ "/etc/ssl/cert.pem")))
+ (substitute* "http.c"
+ (("/etc/ssl/cert.pem") pem))
+ #t)))
(delete 'configure)))) ; no './configure' script
(native-inputs
`(("pkg-config" ,pkg-config)))