summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/django.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b4ca3ab4ec..f30ec2c051 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -929,8 +929,9 @@ using Python multiprocessing.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "python" "django-admin.py"
- "test" "--settings=settings"))))))
+ (invoke "django-admin"
+ "test" "--settings=test_project.settings"
+ "--pythonpath=."))))))
(propagated-inputs
`(("python-django" ,python-django)))
(home-page "https://github.com/jazzband/django-sortedm2m")