summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b553d4534a..3463ac85a7 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6378,6 +6378,15 @@ output.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
+ ;; name.
+ (substitute* '("Keyboard/ckbcomp")
+ (("\"cat ")
+ (string-append "\"" (which "cat")
+ " ")))
+ #t))
(add-before 'build 'make-doubled-bdfs
(lambda* (#:key inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"