summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d763c92f3b..f3e12ab16f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1014,6 +1014,14 @@ and many external plugins.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-version
+ ;; The version string is usually derived via setuptools-scm, but
+ ;; without the git metadata available, the version string is set to
+ ;; '0.0.0'.
+ (lambda _
+ (substitute* "setup.py"
+ (("setup\\(\\)")
+ (format #f "setup(version=~s)" ,version)))))
(replace 'check
(lambda* (#:key (tests? #t) #:allow-other-keys)
(setenv "TERM" "dumb") ;attempt disabling markup tests