summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f91980819c..d79cb135e6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1867,6 +1867,27 @@ and sensible default behaviors into your setuptools run.")
(define-public python2-pbr-0.11
(package-with-python2 python-pbr-0.11))
+(define-public python-pbr
+ (package (inherit python-pbr-0.11)
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pbr" version))
+ (sha256
+ (base32
+ "0jcny36cf3s8ar5r4a575npz080hndnrfs4np1fqhv0ym4k7c4p2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-fixtures" ,python-fixtures)
+ ("python-pip" ,python-pip)))
+ (properties `((python2-variant . ,(delay python2-pbr))))))
+
+(define-public python2-pbr
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-pbr)))))
+
(define-public python-fixtures
(package
(name "python-fixtures")