summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/java-compression.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/java-compression.scm b/gnu/packages/java-compression.scm
index 5f653bcc94..19b11954c1 100644
--- a/gnu/packages/java-compression.scm
+++ b/gnu/packages/java-compression.scm
@@ -291,7 +291,7 @@ It can be used as a replacement for the Apache @code{CBZip2InputStream} /
(name "java-xz")
(version "1.6")
(source (origin
- (method url-fetch)
+ (method url-fetch/zipbomb)
(uri (string-append "https://tukaani.org/xz/xz-java-" version ".zip"))
(sha256
(base32
@@ -301,12 +301,6 @@ It can be used as a replacement for the Apache @code{CBZip2InputStream} /
`(#:tests? #f; no tests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- ;; Our build system enters the first directory in the archive, but
- ;; the package is not contained in a subdirectory
- (chdir "..")
- #t))
(add-before 'install 'generate-pom
(lambda _
(copy-file "maven/pom_template.xml" "pom.xml")