summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/idris.scm12
-rw-r--r--gnu/packages/patches/idris-disable-test.patch19
3 files changed, 28 insertions, 4 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6f66021c78..370719f4d3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1179,6 +1179,7 @@ dist_patch_DATA = \
%D%/packages/patches/icu4c-CVE-2020-10531.patch \
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
%D%/packages/patches/id3lib-UTF16-writing-bug.patch \
+ %D%/packages/patches/idris-disable-test.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
%D%/packages/patches/inetutils-hurd.patch \
%D%/packages/patches/inkscape-poppler-0.76.patch \
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index 1982d7cf07..ca2772b904 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2018 Alex ter Weele <alex.ter.weele@gmail.com>
-;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2019, 2021 Eric Bavier <bavier@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,7 +38,7 @@
(define-public idris
(package
(name "idris")
- (version "1.3.2")
+ (version "1.3.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -46,10 +46,12 @@
"idris-" version "/idris-" version ".tar.gz"))
(sha256
(base32
- "0wychzkg0yghd2pp8fqz78vp1ayzks191knfpl7mhh8igsmb6bc7"))))
+ "1pachwc6msw3n1mz2z1r1w6h518w9gbhdvbaa5vi1qp3cn3wm6q4"))
+ (patches (search-patches "idris-disable-test.patch"))))
(build-system haskell-build-system)
(native-inputs ;For tests
`(("perl" ,perl)
+ ("ghc-cheapskate" ,ghc-cheapskate)
("ghc-tasty" ,ghc-tasty)
("ghc-tasty-golden" ,ghc-tasty-golden)
("ghc-tasty-rerun" ,ghc-tasty-rerun)))
@@ -98,7 +100,8 @@
(add-after 'unpack 'update-constraints
(lambda _
(substitute* "idris.cabal"
- (("ansi-terminal < 0\\.9") "ansi-terminal < 0.10"))
+ (("ansi-terminal < 0\\.9") "ansi-terminal < 0.10")
+ (("cheapskate >= 0\\.1\\.1\\.2 && < 0\\.2") "cheapskate >= 0.1.1.1 && < 0.2"))
#t))
(add-before 'configure 'set-cc-command
(lambda _
@@ -118,6 +121,7 @@
(add-after 'install 'check
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(let ((out (assoc-ref outputs "out")))
+ (chmod "test/scripts/timeout" #o755) ;must be executable
(setenv "TASTY_NUM_THREADS" (number->string (parallel-job-count)))
(setenv "IDRIS_CC" "gcc") ;Needed for creating executables
(setenv "PATH" (string-append out "/bin:" (getenv "PATH")))
diff --git a/gnu/packages/patches/idris-disable-test.patch b/gnu/packages/patches/idris-disable-test.patch
new file mode 100644
index 0000000000..ec8c7c8451
--- /dev/null
+++ b/gnu/packages/patches/idris-disable-test.patch
@@ -0,0 +1,19 @@
+The "pkg010" test output depends on the version of optparse-applicative being
+used. The expected output requires optparse-applicative >= 0.15.1.0. Skip
+the test for now.
+
+--- idris-1.3.3/test/TestData.hs 2021-01-19 23:05:24.238958262 -0600
++++ idris-1.3.3/test/TestData.hs 2021-01-19 23:10:33.314390997 -0600
+@@ -212,8 +212,10 @@
+ ( 5, ANY ),
+ ( 6, ANY ),
+ ( 7, ANY ),
+- ( 8, ANY ),
+- ( 10, ANY )]),
++ ( 8, ANY )]),
++-- FIXME: Expected output depends on optparse-applicative version.
++-- See https://github.com/idris-lang/Idris-dev/issues/4896
++-- ( 10, ANY )]),
+ ("prelude", "Prelude",
+ [ ( 1, ANY )]),
+ ("primitives", "Primitive types",