summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 35577228f1..d8848f82fa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -242,6 +242,44 @@ giant insects to killer robots and things far stranger and deadlier, and against
the others like yourself, that want what you have.")
(license license:cc-by-sa3.0)))
+(define-public cowsay
+ (package
+ (name "cowsay")
+ (version "3.03")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://web.archive.org/web/20071026043648/"
+ "http://www.nog.net:80/~tony/warez/"
+ "cowsay-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bxj802na2si2bk5zh7n0b7c33mg8a5n2wnvh0vihl9bmjkp51hb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'install)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "sh" "install.sh"
+ (assoc-ref outputs "out")))))
+ (replace 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* (string-append (assoc-ref outputs "out")
+ "/bin/cowsay")
+ "We're done!")))))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page (string-append "https://web.archive.org/web/20071026043648/"
+ "http://www.nog.net:80/~tony/warez/"))
+ (synopsis "Speaking cow text filter")
+ (description "Cowsay is basically a text filter. Send some text into it,
+and you get a cow saying your text. If you think a talking cow isn't enough,
+cows can think too. All you have to do is run @code{cowthink}.")
+ ;; Any version of the GPL.
+ (license license:gpl3+)))
+
(define-public freedoom
(package
(name "freedoom")