summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 74ec1b07d6..81543e1cfc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8381,6 +8381,31 @@ Emacs completion function completing-read, which allows quickly selecting from a
list of candidates.")
(license license:gpl3+)))
+(define-public emacs-consult-dir
+ (package
+ (name "emacs-consult-dir")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/consult-dir")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1cff4ssrn1mw2s5n090pdmwdirnfih8idg5f0ll2bi2djc4hq5kn"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult))
+ (home-page "https://github.com/karthink/consult-dir")
+ (synopsis "Insert paths into minibuffer prompts in Emacs")
+ (description "Consult-dir allows you to easily insert directory
+paths into the minibuffer prompt in Emacs.
+
+When using the minibuffer, you can switch---with completion and filtering
+provided by your completion setup---to any directory you’ve visited recently,
+or to a project or bookmarked directory. The minibuffer prompt will be
+replaced with the directory you choose.")
+ (license license:gpl3+)))
+
(define-public emacs-consult-notmuch
(package
(name "emacs-consult-notmuch")