summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/game-development.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 01db2364df..a22167e31b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -602,6 +602,9 @@ clone.")
(substitute* "tsukundere.scm"
(("exec guile (.*)" _ args)
(string-append
+ ;; XXX: Prevent Guile-SDL2 from blowing up by not knowing
+ ;; where the SDL2 libaries are.
+ "unset LD_LIBRARY_PATH\n"
(format #f "export GUILE_LOAD_PATH=\"~@?\"~%"
"~{~a~^:~}" (map scm pkgs))
(format #f "export GUILE_LOAD_COMPILED_PATH=\"~@?\"~%"