summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9205e958c0..099c3e6c5b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6780,4 +6780,27 @@ which automatically lift operations introduced by monad transformers through
other transformers.")
(license license:bsd-3)))
+(define-public ghc-findbin
+ (package
+ (name "ghc-findbin")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/FindBin/FindBin-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "197xvn05yysmibm1p5wzxfa256lvpbknr5d1l2ws6g40w1kpk717"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/audreyt/findbin")
+ (synopsis "Get the absolute path of the running program")
+ (description
+ "This module locates the full directory of the running program, to allow
+the use of paths relative to it. FindBin supports invocation of Haskell
+programs via \"ghci\", via \"runhaskell/runghc\", as well as compiled as
+an executable.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here