summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/messaging.scm16
2 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e19c3d4659..9bc5036cf6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -478,8 +478,6 @@ test coverage and has a web user interface that will refresh automatically.")
(home-page "https://github.com/smartystreets/goconvey")
(license license:expat)))
-;; XXX When updating, check whether ZNC's GOOGLETEST-SOURCES can be
-;; switched back to simply using (PACKAGE-SOURCE ...).
(define-public googletest
(package
(name "googletest")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8aeefa64e1..e4f150c817 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -517,21 +517,7 @@ compromised.")
"--with-gtest=googletest/googletest")
#:test-target "test"))
(native-inputs
- `(("googletest-source"
- ;; ZNC 1.7 needs a newer, unreleased googletest (a release is planned
- ;; <https://github.com/google/googletest/issues/1583>, so don't update
- ;; the public GOOGLETEST to an unstable version). The commit is taken
- ;; from ‘third_party/googletest’ in the ZNC git repository.
- ,(let ((commit "9737e63c69e94ac5777caa0bc77c77d5206467f3"))
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/googletest")
- (commit commit)))
- (file-name (git-file-name "googletest-for-znc" commit))
- (sha256
- (base32
- "0ya36n8d62zbxk6p22yffgx43mqhx2fz41gqqwbpdshjryf3wvxj")))))
+ `(("googletest-source" ,(package-source googletest))
("pkg-config" ,pkg-config)
("perl" ,perl)
("python" ,python)))