summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 46fbb03049..805675696d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -468,19 +468,15 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"-openssl-linked"
;; explicitly link with dbus instead of dlopening it
"-dbus-linked"
- ;; drop special machine instructions not supported
- ;; on all instances of the target
+ ;; don't use the precompiled headers
+ "-no-pch"
+ ;; drop special machine instructions that do not have
+ ;; runtime detection
,@(if (string-prefix? "x86_64"
(or (%current-target-system)
(%current-system)))
'()
'("-no-sse2"))
- "-no-sse3"
- "-no-ssse3"
- "-no-sse4.1"
- "-no-sse4.2"
- "-no-avx"
- "-no-avx2"
"-no-mips_dsp"
"-no-mips_dspr2")))))
(add-after 'install 'patch-qt_config.prf