summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2f0ef52613..45c28106e7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4444,13 +4444,13 @@ parts of it.")
,@(let ((system (or (%current-target-system) (%current-system))))
(cond
((or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system))
- '("DYNAMIC_ARCH=1"))
- ;; On some of these architectures the CPU can't be detected.
- ((or (string-prefix? "powerpc64le" system)
+ (string-prefix? "i686" system)
+ (string-prefix? "powerpc64le" system)
(string-prefix? "aarch64" system))
- '("DYNAMIC_ARCH=1"
- "TARGET=GENERIC"))
+ ;; Dynamic older enables a few extra CPU architectures that
+ ;; were released before 2010.
+ '("DYNAMIC_ARCH=1" "DYNAMIC_OLDER=1" "TARGET=GENERIC"))
+ ;; On some of these architectures the CPU can't be detected.
;; On MIPS we force the "SICORTEX" TARGET, as for the other
;; two available MIPS targets special extended instructions
;; for Loongson cores are used.