summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8ad43b8aa4..9e7d4113ab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3426,10 +3426,11 @@ Betamax that may possibly end up in the main package.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- ;; Some of the 'integration' tests require network access or
- ;; login credentials.
- (invoke "nosetests" "--exclude=integration"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Some of the 'integration' tests require network access or
+ ;; login credentials.
+ (invoke "nosetests" "--exclude=integration")))))))
(native-inputs
`(("python-docutils" ,python-docutils)
("python-mock" ,python-mock)