summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2a00ab1d2f..0014783b4a 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -699,8 +699,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; When `configure' checks for ltdl availability, it
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
- ''("LDFLAGS=-ldl"
- "--enable-mini-gmp"))
+ `(list "LDFLAGS=-ldl" "--enable-mini-gmp"
+ ,@(if (hurd-target?)
+ '("--disable-jit")
+ '())))
((#:phases phases '%standard-phases)
`(modify-phases ,phases