summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b3fbeb56ad..e3db1c5a1d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6231,10 +6231,10 @@ system calls. Second, exposing the internal buffer allows the user to work
with data in place, which avoids another copy.")
(license license:gpl3)))
-(define-public rust-buffering-0.3
+(define-public rust-buffering-0.4
(package
(name "rust-buffering")
- (version "0.3.4")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
@@ -6242,12 +6242,12 @@ with data in place, which avoids another copy.")
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32 "11cyq2nm569j028g93jxk00h8nfwc3l6n3hqw79w34na01p3lq97"))))
+ (base32 "1wmgy84j5scbndzx7mccz07z34n98fwnfah1zd5kzqjaif5iqk76"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-buffering-nocopy-macro" ,rust-buffering-nocopy-macro-0.1))))
+ (("rust-buffering-nocopy-macro" ,rust-buffering-nocopy-macro-0.2))))
(home-page "https://github.com/jbaublitz/buffering")
(synopsis "Library primarily designed for network packet buffer operations")
(description
@@ -6255,6 +6255,24 @@ with data in place, which avoids another copy.")
buffer operations.")
(license license:bsd-3)))
+(define-public rust-buffering-0.3
+ (package
+ (inherit rust-buffering-0.4)
+ (name "rust-buffering")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "buffering" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "11cyq2nm569j028g93jxk00h8nfwc3l6n3hqw79w34na01p3lq97"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-buffering-nocopy-macro" ,rust-buffering-nocopy-macro-0.1))))))
+
(define-public rust-buffering-nocopy-macro-0.2
(package
(name "rust-buffering-nocopy-macro")