summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index b3d8992b54..6045c16b8f 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -291,6 +291,10 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(guix build gnu-build-system)
(guix build utils))
+ ;; The test suite takes many times longer than building and
+ ;; can easily fail on smaller machines when they run out of memory.
+ #:tests? ,(not (target-aarch64?))
+
;; Do not strip binaries to keep support for full backtraces.
;; See https://github.com/JuliaLang/julia/issues/17831
#:strip-binaries? #f