summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 05e5165d3f..38ac6c526c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -863,12 +863,7 @@ is part of the GNOME accessibility project.")
(propagated-inputs
`(("atk" ,atk)
("cairo" ,cairo)
- ;; SVG support is optional and requires librsvg, which pulls in rust.
- ;; Rust is not supported well on every architecture yet.
- ("gdk-pixbuf" ,(if (string-prefix? "x86_64" (or (%current-target-system)
- (%current-system)))
- librsvg
- gdk-pixbuf))
+ ("gdk-pixbuf" ,(librsvg-for-system))
("glib" ,glib)
("pango" ,pango)))
(inputs