summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 26cb67661e..e6a2f42ee3 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -648,10 +648,10 @@ public keys and can roam across IP addresses.")
(delete 'configure) ;no configure script
(add-before 'build 'setup-environment
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "CFLAGS"
- (string-append "-DPPPD=\""
- (assoc-ref inputs "ppp")
- "/sbin/pppd\""))
+ (substitute* "l2tp.h"
+ (("/usr/sbin/pppd")
+ (string-append (assoc-ref inputs "ppp")
+ "/sbin/pppd")))
(setenv "KERNELSRC"
(assoc-ref inputs "linux-libre-headers"))
#t)))