summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/education.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 99e7b669b4..a4081cc374 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -758,6 +758,13 @@ adjust the level of difficulty.")
(ice-9 match))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-update-check
+ ;; Don't ‘phone home’ unasked to check for updates.
+ (lambda _
+ (substitute* "aqt/update.py"
+ (("requests\\.post")
+ "throw.an.exception.instead"))
+ #t))
(delete 'configure) ;no configure script
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)