summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 83f6a4d9c7..756a190ae9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8608,28 +8608,31 @@ asynchronously, with Counsel and Ivy. Simply call
(license license:gpl3+))))
(define-public emacs-counsel-projectile
- (package
- (name "emacs-counsel-projectile")
- (version "0.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ericdanan/counsel-projectile")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1k4n5lw6wwbgpwv0dg9dw0bjzi0hvbgkzrs1zmq36yhfz6y8gwnh"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-counsel" ,emacs-counsel)
- ("emacs-projectile" ,emacs-projectile)))
- (home-page "https://github.com/ericdanan/counsel-projectile")
- (synopsis "Enhance Projectile with Ivy")
- (description
- "This package uses Ivy to provide additional actions for Projectile
+ ;; Use a recent commit in order to fix recent breakage with Ivy.
+ (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
+ (revision "0"))
+ (package
+ (name "emacs-counsel-projectile")
+ (version (git-version "0.3.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ericdanan/counsel-projectile")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10afil6grwxj1x8fxd3ar7ikw3s3hzrkjsjin8wzchbz04389l7s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-counsel" ,emacs-counsel)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/ericdanan/counsel-projectile")
+ (synopsis "Enhance Projectile with Ivy")
+ (description
+ "This package uses Ivy to provide additional actions for Projectile
commands and replacements for existing functions.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-qml-mode
(package