summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 59cd7107bf..61db9febb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7229,6 +7229,31 @@ The output of all running processes is collected by honcho and
displayed.")
(license license:expat)))
+(define-public python-pebble
+ (package
+ (name "python-pebble")
+ (version "4.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pebble" version))
+ (sha256
+ (base32 "16siqc3brbk7dp4d9sg48bjl6a8wyy24aib3il1hf4y2624draxh"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "python" "-m" "pytest" "-sv"))))))
+ (home-page "https://github.com/noxdafox/pebble")
+ (synopsis "Threading and multiprocessing for Python")
+ (description
+ "Pebble aims to help manage threads and processes in an easier way. It
+wraps Python's standard library threading and multiprocessing objects.")
+ (license license:lgpl3+)))
+
(define-public python-pexpect
(package
(name "python-pexpect")