summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pcre.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index cf8c1fb2b0..10e29cf6ca 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -109,7 +109,9 @@ POSIX regular expression API.")
"--enable-pcre2-16"
"--enable-pcre2-32"
;; pcre2_jit_test fails on powerpc32.
- ,@(if (target-ppc32?)
+ ;; riscv64-linux is an unsupported architecture.
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
'()
`("--enable-jit"))
"--disable-static")