summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3f7fcb8ae9..2482a37bf5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10148,3 +10148,26 @@ It provides syntax highlighting and automatic indentation and
comes with sml-proc which allows interaction with an inferior SML
interactive loop.")
(license license:gpl3+)))
+
+(define-public emacs-eros
+ (let ((commit "a42e45c9b2397156c684330b0fc90ee0eba773f5")
+ (revision "1"))
+ (package
+ (name "emacs-eros")
+ (version (string-append "0.0.1" "-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xiongtx/eros.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0whlsq90v13fz69k3wjrwcwb9gkpfxqjd75mg3nrp85j9nwhb5i4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/xiongtx/eros")
+ (synopsis "Evaluation result overlays")
+ (description "@code{eros} provides evaluation result overlays.")
+ (license license:gpl3+))))