summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/emacs-xyz.scm8
2 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e4b01170e3..ab34958cf7 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1166,6 +1166,34 @@ biscuiteer.")
chromstaR package.")
(license license:gpl3)))
+(define-public r-chromvarmotifs
+ (let ((commit "38bed559c1f4770b6c91c80bf3f8ea965da26076")
+ (revision "1"))
+ (package
+ (name "r-chromvarmotifs")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GreenleafLab/chromVARmotifs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i9v1m1hrg1lkd2pnkj5nnrpks6vhhhpbdhsfl2lmjak4npxxr5q"))))
+ (properties `((upstream-name . "chromVARmotifs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-tfbstools" ,r-tfbstools)))
+ (home-page "https://github.com/GreenleafLab/chromVARmotifs")
+ (synopsis "Stores motif collections for use with motifmatchr or chromVAR")
+ (description
+ "This package stores motif collections as lists of @dfn{position
+frequency matrix} (PWMatrixList) objects provided by the @code{TFBSTools}
+package for use in R with packages like @code{motifmatchr} or
+@code{chromVAR}.")
+ (license license:expat))))
+
(define-public r-copyhelper
(package
(name "r-copyhelper")
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ba7fb8077..6c00de8ce5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -282,7 +282,7 @@ e.g. emacs-geiser-guile for Guile.")
(define-public emacs-geiser-guile
(package
(name "emacs-geiser-guile")
- (version "0.18")
+ (version "0.19")
(source
(origin
(method git-fetch)
@@ -291,7 +291,7 @@ e.g. emacs-geiser-guile for Guile.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0gndf0w8dbv54bzc04svp2ck8wypa7i3b8kpixf6rkg91l79xpci"))))
+ (base32 "1r21d61b2l65gr90s2h83xfnjgzc4n9ris4g5n3ifvdi3pyga6k9"))))
(build-system emacs-build-system)
(arguments
'(#:include (cons "^src/" %default-include)
@@ -8119,7 +8119,7 @@ single theme but a set of guidelines with numerous implementations.")
(define-public emacs-solaire-mode
(package
(name "emacs-solaire-mode")
- (version "2.0.3")
+ (version "2.0.4")
(source
(origin
(method git-fetch)
@@ -8128,7 +8128,7 @@ single theme but a set of guidelines with numerous implementations.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wq5ckwx3wv4c4l8f9hz3ak6v5wy4lg5yh8xlsgn1h1x6yf8afpp"))))
+ (base32 "1lkm09wznal0grpz61ikc77mjrri1x1bi79qwyf1cah9s0wv3isq"))))
(build-system emacs-build-system)
(home-page "https://github.com/hlissner/emacs-solaire-mode")
(synopsis "Change background of file-visiting buffers in Emacs")