summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/android.scm2
-rw-r--r--gnu/packages/disk.scm4
-rw-r--r--gnu/packages/golang.scm5
-rw-r--r--gnu/packages/ipfs.scm4
-rw-r--r--gnu/packages/java.scm2
-rw-r--r--gnu/packages/linux.scm10
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/rails.scm2
-rw-r--r--gnu/packages/ruby.scm2
-rw-r--r--guix/build/go-build-system.scm4
-rw-r--r--guix/store/deduplication.scm4
12 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 80eaab3e5c..7d5de08be9 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -538,7 +538,7 @@ that is safe to use for user space. It also includes
(native-inputs
`(("android-core" ,(android-platform-system-core version))))
(home-page "https://developer.android.com/")
- (synopsis "Android ext4 filesystem utils")
+ (synopsis "Android ext4 file system utilities")
(description "@code{android-ext4-utils} is a library in common use by the
Android core.")
(license license:asl2.0)))
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index e52c4614c1..c8d2af88ca 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -808,9 +808,9 @@ LVM D-Bus API).")
("json-glib" ,json-glib)
("libblkid" ,util-linux)))
(home-page "https://rmlint.rtfd.org")
- (synopsis "Remove duplicates and other lint from the filesystem")
+ (synopsis "Remove duplicates and other lint from the file system")
(description "@command{rmlint} finds space waste and other broken things
-on your filesystem and offers to remove it. @command{rmlint} can find:
+on your file system and offers to remove it. @command{rmlint} can find:
@itemize
@item duplicate files and duplicate directories,
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3d02..5caf7a89f8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3168,8 +3168,9 @@ have super fancy logs.")
(arguments
'(#:import-path "github.com/kr/fs"))
(home-page "https://github.com/kr/fs")
- (synopsis "Filesystem-related functions for Go")
- (description "Package fs provides filesystem-related functions.")
+ (synopsis "File-system-related functions for Go")
+ (description
+ "The fs package provides file-system-related Go functions.")
(license license:bsd-3))))
(define-public go-github-com-direnv-go-dotenv
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 6b8afd5f53..4f61f2ba66 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -152,7 +152,7 @@ that are shared between @command{go-ipfs/commands} and its rewrite
(home-page "https://github.com/whyrusleeping/gx")
(synopsis "Package management tool using IPFS")
(description "@command{gx} is a packaging tool built around the
-distributed, content addressed filesystem IPFS. It aims to be flexible,
+distributed, content addressed file system IPFS. It aims to be flexible,
powerful and simple.")
(license license:expat)))
@@ -244,7 +244,7 @@ written in Go.")
#t))))))
(home-page "https://ipfs.io")
(synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol")
- (description "IPFS is a global, versioned, peer-to-peer filesystem. It
+ (description "IPFS is a global, versioned, peer-to-peer file system. It
combines good ideas from Git, BitTorrent, Kademlia, SFS, and the Web. It is
like a single bittorrent swarm, exchanging git objects. IPFS provides an
interface as simple as the HTTP web, but with permanence built in. You can
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a47a1a008c..bcd3f98ce0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -10296,7 +10296,7 @@ authentication, HTTP state management, and HTTP connection management.")
("java-commons-net" ,java-commons-net)
("java-jsch" ,java-jsch)))
(home-page "http://commons.apache.org/proper/commons-vfs/")
- (synopsis "Java filesystem library")
+ (synopsis "Java file system library")
(description "Commons VFS provides a single API for accessing various
different file systems. It presents a uniform view of the files from various
different sources, such as the files on local disk, on an HTTP server, or
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f3ed832417..62a98ec739 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3361,7 +3361,7 @@ write access to exFAT devices.")
(home-page "https://sourceforge.net/projects/fuseiso/")
(synopsis "Mount ISO file system images")
(description
- "FuseISO is a FUSE module to mount ISO filesystem images (.iso, .nrg,
+ "FuseISO is a FUSE module to mount ISO file system images (.iso, .nrg,
.bin, .mdf and .img files). It supports plain ISO9660 Level 1 and 2, Rock
Ridge, Joliet, and zisofs.")
(license license:gpl2)))
@@ -3694,7 +3694,7 @@ from userspace.")
;; If users install ntfs-3g, they probably want to make it the
;; default driver as well, so we opt for sensible defaults and link
;; mount.ntfs to mount.ntfs-3g. (libmount tries to run mount.ntfs to
- ;; mount NTFS filesystems.)
+ ;; mount NTFS file systems.)
(add-after 'install 'install-link
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -5240,9 +5240,9 @@ file systems.")
`(("autoconf" ,autoconf)
("automake" ,automake)))
(home-page "https://github.com/jeremie-koenig/genext2fs")
- (synopsis "Generate ext2 filesystem as a normal user")
- (description "This package provides a program to general an ext2
-filesystem as a normal (non-root) user. It does not require you to mount
+ (synopsis "Generate ext2 file system as a normal user")
+ (description "This package provides a program to generate an ext2
+file system as a normal (non-root) user. It does not require you to mount
the image file to copy files on it, nor does it require that you become
the superuser to make device nodes.")
(license license:gpl2)))
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6708a761eb..1556e103d5 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1000,8 +1000,8 @@ for packaging and deployment of cross-compiled Windows applications.")
(description
"@code{libostree} is both a shared library and suite of command line
tools that combines a \"git-like\" model for committing and downloading
-bootable filesystem trees, along with a layer for deploying them and managing
-the bootloader configuration.")
+bootable file system trees, along with a layer for deploying them and managing
+the boot loader configuration.")
(license license:lgpl2.0+)))
(define-public flatpak
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 669d465e27..c7d7ff932b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14423,7 +14423,7 @@ introspection.")
(synopsis "File transport adapter for Requests")
(description
"Requests-File is a transport adapter for use with the Requests Python
-library to allow local filesystem access via file:// URLs.")
+library to allow local file system access via @code{file://} URLs.")
(license license:asl2.0)))
(define-public python2-requests-file
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index e623f9b8c4..86ce1514f0 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -602,7 +602,7 @@ can also be launched manually in any page.")
(synopsis "Advisory locking for ActiveRecord")
(description
"The With advisory lock gem adds advisory locking to ActiveRecord for
-PostgreSQL and MySQL. SQLite is also supported, but this uses the filesystem
+PostgreSQL and MySQL. SQLite is also supported, but this uses the file system
for locks.")
(home-page "https://closuretree.github.io/with_advisory_lock/")
(license license:expat)))
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8bde577229..9370f59e2e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2870,7 +2870,7 @@ conversion to (X)HTML.")
`(("ruby-listen" ,ruby-listen)))
(synopsis "Run a process, and restart when some monitored files change")
(description
- "Rerun is a tool to launch programs, then monitor the filesystem, and
+ "Rerun is a tool to launch programs, then monitor the file system, and
restart the program when any of the monitored files change. It's written in
Ruby, but can be used for all programs.")
(home-page "https://github.com/alexch/rerun/")
diff --git a/guix/build/go-build-system.scm b/guix/build/go-build-system.scm
index 1a716cea77..282df19f24 100644
--- a/guix/build/go-build-system.scm
+++ b/guix/build/go-build-system.scm
@@ -42,7 +42,7 @@
;; structure called a 'workspace' [1]. This workspace can be found by Go via
;; the GOPATH environment variable. Typically, all Go source code and compiled
;; objects are kept in a single workspace, but GOPATH may be a list of
-;; directories [2]. In this go-build-system we create a filesystem union of
+;; directories [2]. In this go-build-system we create a file system union of
;; the Go-language dependencies. Previously, we made GOPATH a list of store
;; directories, but stopped because Go programs started keeping references to
;; these directories in Go 1.11:
@@ -127,7 +127,7 @@
;; Code:
(define* (setup-go-environment #:key inputs outputs #:allow-other-keys)
- "Prepare a Go build environment for INPUTS and OUTPUTS. Build a filesystem
+ "Prepare a Go build environment for INPUTS and OUTPUTS. Build a file system
union of INPUTS. Export GOPATH, which helps the compiler find the source code
of the package being built and its dependencies, and GOBIN, which determines
where executables (\"commands\") are installed to. This phase is sometimes used
diff --git a/guix/store/deduplication.scm b/guix/store/deduplication.scm
index 8ca16a4cd8..d42c40932c 100644
--- a/guix/store/deduplication.scm
+++ b/guix/store/deduplication.scm
@@ -79,8 +79,8 @@ unused by the time you create anything with that name, but a good shot."
(define* (get-temp-link target #:optional (link-prefix (dirname target)))
"Like mkstemp!, but instead of creating a new file and giving you the name,
it creates a new hardlink to TARGET and gives you the name. Since
-cross-filesystem hardlinks don't work, the temp link must be created on the
-same filesystem - where in that filesystem it is can be controlled by
+cross-file-system hardlinks don't work, the temp link must be created on the
+same file system - where in that file system it is can be controlled by
LINK-PREFIX."
(let try ((tempname (tempname-in link-prefix)))
(catch 'system-error